How Vehicle Visibility in Command Center Works

When specialists are logged into their Specialist App they are shown on the Command Center Map as vehicle icons. The mobile phone the Specialist App is installed on sends its location real-time to update the Command Center Map.

Issues

On the Command Center Map, when specialists are logged into their Specialist App:

  • Vehicle icon(s) are showing at the incorrect location.

  • Vehicle icon(s) are stuck/frozen at a previous location.

  • The vehicle speed(s) are stuck/frozen.

  • Vehicle icon(s) are blinking in one or more locations.

  • The driving routes are showing, but the vehicle icon(s) are not showing.

  • Vehicle icon(s) are not showing at all.

Typical Causes

Important: Most of the time, vehicle visibility issues are caused by incorrect settings or issues with the mobile phone the Specialist App is installed on. When the mobile phone is unable to send its current location to the Command Center, the vehicle icon remains at the last known location or disappears.

  • The Command Center has been open as an idle tab/window for a while.

  • The Specialist App is not in the foreground of the mobile phone.

  • The mobile phone has been locked or turned off.

  • The mobile phone has a poor internet connection or no internet at all.

  • The location settings for the Specialist App and/or the mobile phone are configured incorrectly or turned off. This includes when phone manufacturer updates, such as operating system updates, require a confirmation or reconfiguration of previously configured app settings.

  • In rare cases, the mobile phone being connected to the vehicle via Bluetooth causes the Specialist App’s navigation system to clash with the vehicle’s navigation system. Therefore, if visibility issues occur, it is recommended to keep Bluetooth turned off while using the Specialist App.

How to Troubleshoot

Disclaimer: These are general steps for checking and configuring phone settings as the specific steps vary by phone make and model. If needed, consult your phone manufacturer’s help pages, manuals, etc. for the specific steps for your mobile phone.

Try, in this order:

1. Refresh Internet Browser

Refresh the internet browser the Command Center is on.

2. Make Sure Specialist App is in the Foreground of Unlocked, Turned On Phone

Make sure the Specialist App is open in the foreground, not the background, of the phone. Also make sure that the phone is turned on and unlocked.

3. Check Phone’s Internet Connection

Open the internet browser or the Google Maps app on the phone. Type something and see if it gives a result. If not, check the phone’s settings and make sure:

  • Cellular data is turned on

  • WiFi is turned off*

  • Airplane mode is turned off

*Sometimes WiFi signals aren’t strong enough to support a stable internet connection or regularly disconnect from the phone as the driver leaves the station. Therefore, using the phone’s cellular data instead is recommended.

4. Check Specialist App Location and Data Settings

Open Settings on the phone. Search for Quickride Driver and tap on it.

  • Look at Location or Permissions and make sure that location access is allowed at the highest possible level.

  • Look at Cellular Data, Mobile Data, or Data Usage and make sure that the use of cellular data, background data, unrestricted data, and/or data saver is allowed.

5. Make Sure Phone’s Location Services are Turned On

Open Settings on the phone. Search for Location and tap on it. Make sure Location / Location Services are turned on.

6. Turn Off Phone’s Bluetooth

Open Settings on the phone. Search for Bluetooth and tap on it.

  • Turn Bluetooth off.

  • Delete the history of Bluetooth devices the phone has previously connected to to prevent future automatic pairing with a shuttle vehicle.

7. Clear Specialist App Cache (On Android phones only)

Open Settings on the phone. Search for Quickride Driver and tap on it. Tap Storage. Tap Clear Cache.

8. Restart the Phone

Log out of the Specialist App. Restart the phone.

9. Uninstall and Reinstall Specialist App

Important: This should only be done if all other steps have been tried and have not fixed the issue.

Uninstall/ delete the Specialist App. Then reinstall it. When logging in to the Specialist App for the first time after the reinstall, allow notifications and the highest location settings.

Did this answer your question?